Scheduled for February 19, 2022 at 11:51 AM – 12:51 PM
Completed
February 19, 2022 at 12:51 PMCompleted
February 19, 2022 at 12:51 PMThe scheduled maintenance has been completed.
In progress
February 19, 2022 at 11:52 AMIn progress
February 19, 2022 at 11:52 AMScheduled maintenance is currently in progress. We will provide updates as necessary.
Planned
February 19, 2022 at 11:50 AMPlanned
February 19, 2022 at 11:50 AMWe are currently updating some of our infrastructure software. This makes sure that the Jadua Servers are the most reliable and secure they can be.